Tux Guitar

Open Discussion

Subject size of fonts



Author Message
Giuliano Colivicchi (Italy)
Post: Jun 11th 2009 at 10:14 AM

There is any tricks to enlarge the size of fonts and tabs?
My sight is weak!

Thanks in advance for any suggestion


Back to Top
 
Todd
Post: Jun 21st 2009 at 1:28 PM

Just go to tools/settings/styles in the top menus and the fonts are all changeable, hope that helps!


Back to Top
 
vanferry
Post: Jul 27th 2009 at 4:59 AM

Actually Tod 's method can't work, I'm looking into source code for several weeks, there is a (int)scoreLineSpacing in ViewLayout, means how many pixels between two staff lines. default is 8, if you want bigger score, need to change this.


Back to Top
 
Julian
Post: Jul 27th 2009 at 4:13 PM

vanferry, Todd answer how to change the font size ( that is different than the tab/score size )
if you want to change the tab/score size..
you could open the tuxguitar configuration file and add these lines:
tab.line-spacing=??
score.line-spacing=??

where ?? you can set values greater than defaults..
and it will scale the fonts too..


Back to Top
 
Anonymous
Post: Aug 21st 2009 at 7:57 AM

where is the configuration file? i have been trying to enlarge those things for 6 months now


Back to Top
 
A Nonny Mouse
Post: Aug 22nd 2009 at 4:27 AM

How would one change the size of the tab/score in Windows?

The font size change is pretty easy, as noted above, but then the note numbers overlap each other, especially on chords.

I have a large screen, and would like to make the tab/score 1/3rd bigger, so that the notes can be size 10 or 12

Thanks


Back to Top
 
Anonymous
Post: Sep 3rd 2009 at 2:39 AM

for windows:
look into {User Home Path}/.tuxguitar-1.1/config.properties
add or change:
tab.line-spacing=??
score.line-spacing=8 //default

on other platform, check similar position.


Back to Top
 
Jon Moss
Post: Oct 19th 2009 at 12:16 AM

This did not help with printing the score. Yes, the screen size of the tab and the score changed dramatically (I set them both to 36 in the config file). However, Print Preview and actually printing it still gives unreadable tabs.

We have Kubuntu Jaunty 64 bit. We are frustrated to the point of installing PowerTab under Wine.

Any help or suggestions?


Back to Top
 
jkorp
Post: Oct 21st 2009 at 12:39 AM

This file did not exist on my Win system. I tried to create it but it didn't work. Is this a registry key perhaps?


Back to Top
 
alxobr
Post: Feb 13th 2010 at 5:50 PM

Hi all,

I cannot get readable fonts for the menus and dialogs in Linux. Changing whatever font (default, note, lyrics, text, time signature ) in the Tools/Settings/Style has no effect.

Thanks for any hint


Back to Top
 
Matt
Post: Apr 24th 2010 at 3:51 PM

It isn't under the install directory, it is under Docs and Settings on Windows.

C:Documents and Settings.tuxguitar-1.2


Back to Top
 
Matt
Post: Apr 24th 2010 at 3:56 PM

tab.line-spacing=18 works for me with font size Verdana 8


Back to Top
 
me
Post: Aug 31st 2010 at 1:44 AM

none of this information is helpful to me, i use windows and followed all the instruction but the print font is still small


Back to Top
 
Fritz
Post: Sep 9th 2010 at 8:56 AM

Print font is set on a different location:
Use Settings Dialog (F7) on Tab Styles and second Headline "Printer Styles". Default Settings are "Sans 6px" wich is obvious very small. It's readable when you use Sans 10 or Sans 12.


Back to Top
 
Me
Post: Oct 23rd 2010 at 8:20 PM

the staff size and font is ridiculously small

default it to a normal setting for crying out loud

seriously where is the logic behind the micro tab - there is none

you throw the page on a table your head is what 3 feet from it...c'mon, its impossible to read


Back to Top
 
A Nonny Mouse
Post: Dec 30th 2010 at 6:02 AM

I was able to enlarge my note fonts with the above instructions in Windows XP (with the config file in Documents and Settings)

However, I have a new computer with windows 7 which does not have the old style documents and settings folders. Instead there is a users/name/appdata folder where I would expect to find the tuxguitar files but alas they are not there.

Does anyone know where to find the tuxguitar config file under windows 7?

Thanks


Back to Top
 
Anonymous
Post: Feb 9th 2011 at 4:20 PM

Export as PDF then print the PDF


Back to Top
 
pjmusic
Post: Feb 27th 2011 at 1:00 PM

Sorry but we have to wait 1.3 version...
because font sizes are inside tuxguitar.exe :

tuxguitar.exe - 7 matches in 188,242 lines.
tuxguitar.exe 72918 font.text=Tahoma,8,0
tuxguitar.exe 72919 font.lyric=Tahoma,7,0
tuxguitar.exe 72921 font.chord=Tahoma,8,0
tuxguitar.exe 72923 font.printer.default=Tahoma,6,0
tuxguitar.exe 72924 font.printer.text=Tahoma,8,0
tuxguitar.exe 72926 font.printer.lyric=Tahoma,7,0
tuxguitar.exe 72929 font.printer.chord=Tahoma,8,0


Back to Top
 
Kuruhyoo
Post: Mar 29th 2011 at 11:28 PM

Download the standard, Java driven version of Tux Guitar. Following installation, the location of the config file that needs to be altered is:

C:Users(your user name).tuxguitar-1.2config

Open it using Wordpad. The lines you need won't be present in the config file when you open it. You'll have to add the following lines by hand:

tab.line-spacing=xx
score.line-spacing=xx

The default tab.line-spacing value is 10 and the default score.line-spacing is 8. If you want more space for the tab lines increase that spacing. The same for the score lines.

For me the best sizes are as follows, and you can just cut and paste the following lines at the bottom of your config file if you like:

tab.line-spacing=12
score.line-spacing=8

The font sizes can be increased from within TuxGuitar itself. I find for me that the best increases for both printing and view are as follows:

Increase "Note font" size to 8 (I know it stops at 7, but just type in 8 by hand) and the "Time signature" font to 12. Change this for both "General" and "Printer" styles.

Tabs should now be much easier to read both on screen and when printed under Windows 7.


Back to Top
 
kuruhyoo
Post: Mar 30th 2011 at 1:39 AM

Correction, this only helps with the on screen size and not when printing. There doesn't seem to be a straightforward way to increase tab spacing in the final printout, just the font size.


Back to Top
 
guycapuano
Post: Apr 1st 2011 at 4:11 AM

this is a total bummer


Back to Top
 
Chris
Post: Apr 30th 2011 at 12:22 PM

Hi guys,

The same problem was driving me nuts initially, too.

The solution is provided by Fritz above:

There is a separate font size setting for the PRINTER (includes PDF export) versus the SCREEN / EDITOR font size.

Changed both and now it's groovy.

Thanks, Fritz!

Cheers,
Chris


Back to Top
 
Lyssa Gale
Post: Jun 20th 2011 at 10:12 AM

To increase or decrease the size of objects and text on your screen

1. Open Display in Control Panel.

2. On the Settings tab, click Advanced.

3. On the General tab, in the DPI setting list, click the dots per inch (dpi) setting you want to use.

4. If you choose Other in the DPI setting list, you can set custom options in the Custom DPI Setting dialog box either by selecting one of the percentage options in the drop-down list or by clicking on the ruler and dragging the pointer to specify a setting.

5. Restart your computer when prompted.

Lyssa Gale
[url=http://www.allyourfonts.com/]Desktop Fonts[/url]


Back to Top
 
A Nonny Mouse
Post: Sep 2nd 2011 at 7:00 AM

Thanks Kuruhyoo. I set up a thread elsewhere here so I forgot about this one until now.

My install (from the Jet version) did not seem to have the directory as you wrote it.

I did a new install with the non jet, windows installer version, and found the config file at:

Users(your user name)/tuxguitar-1.2/ with the file name being config

This was now similar to the install I did under windows XP so I did what I did then (the same as you outlined above) and it worked great.

So I just needed a re-install.

Thanks for the tip.

To those following this tip:

1) once you add the new lines to the config file, it reintegrates the lines into the document, so you have to hunt a bit to find them if you want to to change them again

2) as noted above, Clicking on Tools->Settings->Styles will allow you to set font note size (I find 8 is a good balance between readability and not smushing the chords together)

Also, thanks for the alternate tip Lyssa, but does that reset the dpi for everything on the computer, or just for tuxguitar? I like the size of things for other programs, so I would only want to change tux guitar. Thanks for the tip though


Back to Top
 
gsoClarke
Post: Sep 4th 2011 at 12:18 AM

The TuxGuitar config file for Windows XP (and others?) isn't under the install directory, it is under Docs and Settings.

C:Documents and Settings.tuxguitar-1.2


Back to Top